This object is in archive! 
Upvote 2

Installation with PHP 5.6

Archived Christian W. 7 years ago

PHP 5.6 has some functions marked as deprecated. The result out of this is that the installation is broken as shown in the attached file.

I changed every entry with "internal_encoding" into "default_encoding" in the file under "<useresponsefolder>/application/3.1.4/library/hotFiles.php".

Now I could install everything without errors.

But I suppose that there are more entries in other fields that use this term. And of course php will raise an error when using this. So... my question is: Is there a solution for this?

Thanks!

Best regards

Christian W.

Replies (5)

photo
1

In the attached screenshot is shown what I meant before.


I've tried to administrate the installed useresponse and it gives me the error about the deprecated internal_encoding setting.

photo
1

From now I've replaced all internal_encoding strings with default_encoding. I've searched with notepad++ within all files and replaced them.


I hope you have another solution for me - that is more professional.


Best regards

Christian W.

photo
1

Hello Christian,

We need some time to review installation on php 5.6 and fix any found issues.

We'll get back to you after review

photo
1

Hello Christian,

We need some time to review installation on php 5.6 and fix any found issues.

We'll get back to you after review

photo
1

Christian,


3.2 release will be ready to work on PHP 5.6. So consider it to be fixed when you get the update in about 1-2 weeks.

Replies have been locked on this page!